WebLogic 61 SP4 和 JDK 1.4 的集成

由 徐永久 发表于 2003年02月17日 22:42。

WebLogic 61 SP3 能够使用 JDK 1.4 ,来支持 Parallel Garbage Collection。 但是到了 61SP4,事情发生了变化。看我是怎样解决的。

解决问题的办法,首先是用相关的关键字搜索 Google。
不用说:就是 WebLogic 6.1 SP4 JDK 1.4 等等。
但是无论在 Web 页面还是新闻组都不能得到结果。

因此,应该去 askbea 的网站,果然在 Bea 的新闻组里,找到了下面的连接:

http://www.genuitec.com/products/JDK14_WLS61.pdf

这就是本文的内容,翻译出来如下:

在 $WL_HOME/lib 下建立 login.conf 文件如下:

ServerLoginModule {
com.sun.security.auth.module.NTLoginModule required debug=true;
};

修改: startWebLogic.sh 中启动 WebLogic 的那行:
为 java 添加:

-Djava.security.auth.login.config=$WL_HOME/lib/login.conf

这样,重新启动 WebLogic 就不会再遇到:

“java.lang.SecurityException: 无法定位登录配置”

的错误了。