升级 PHP 后修改 Lyceum 1.0.3 的问题

PHP
Image via Wikipedia

升级 PHP 从 4.4.8 到 5.2 以后,Lyceum 1.0.3 罢工了,报编码错误,以为是 GFW 的问题,用代理绕过后还是一样,检查代码,解决的办法是在 “wp-blog-header.php” 里的 wp 前添加 echo ” ” 即可。


require(‘private.php’);
if (! isset($wp_did_header)) {

$wp_did_header = true;

require_once( CONFIGPATH . ‘wp-config.php’);

if ( ‘active’ == $blogstatus ){
echo ” “;
wp();
gzip_compression();
require_once(ABSPATH . WPINC . ‘/template-loader.php’);
}
else {
if (!empty($slug))
lyceum_404();
//????? $_SESSION[‘slug_error’] = ‘<strong>ERROR</strong>: The blog requested does not exist or has been deactivated.’;
// wp_redirect(LURL . ‘/portal.php’);
}

}

// endif;

Reblog this post [with Zemanta]